Hi Cuyler and thanks for reading.
You make some great additional points. I’d agree its a trivialized example — coming up with examples for articles proves more frustrating than I had imagined. I’m trying to get better at it, so your feedback helps.
I agree with your point about the method names. Naming is difficult and I took my best guess at what I would have re-named something if I had seen it in a code review. Granted, that leaves out the other party which would, hopefully, lead to even better names.
I agree with you that duplication is a lower priority to readability and maintainability, so being too quick to extract a constant could be dangerous. The reason I chose to extract these to constants was more about those values being pulled from something known (ie the formulae for conversion) rather than being made up. Maybe that wasn’t the right approach. I do agree though the inversion of the ration could have been better declared right before the
converToDegreesCelsius and been more readable. I’ll try to make that update this week.
Thanks for the feedback!